logo
DATABASE RESOURCES PRICING ABOUT US

linux - security update

Description

Several vulnerabilities have been discovered in the Linux kernel that may lead to a privilege escalation, denial of service or information leaks. * [CVE-2022-2585](https://security-tracker.debian.org/tracker/CVE-2022-2585) A use-after-free flaw in the implementation of POSIX CPU timers may result in denial of service or in local privilege escalation. * [CVE-2022-2586](https://security-tracker.debian.org/tracker/CVE-2022-2586) A use-after-free in the Netfilter subsystem may result in local privilege escalation for a user with the CAP\_NET\_ADMIN capability in any user or network namespace. * [CVE-2022-2588](https://security-tracker.debian.org/tracker/CVE-2022-2588) Zhenpeng Lin discovered a use-after-free flaw in the cls\_route filter implementation which may result in local privilege escalation for a user with the CAP\_NET\_ADMIN capability in any user or network namespace. * [CVE-2022-26373](https://security-tracker.debian.org/tracker/CVE-2022-26373) It was discovered that on certain processors with Intel's Enhanced Indirect Branch Restricted Speculation (eIBRS) capabilities there are exceptions to the documented properties in some situations, which may result in information disclosure. Intel's explanation of the issue can be found at * [CVE-2022-29900](https://security-tracker.debian.org/tracker/CVE-2022-29900) Johannes Wikner and Kaveh Razavi reported that for AMD/Hygon processors, mis-trained branch predictions for return instructions may allow arbitrary speculative code execution under certain microarchitecture-dependent conditions. A list of affected AMD CPU types can be found at * [CVE-2022-29901](https://security-tracker.debian.org/tracker/CVE-2022-29901) Johannes Wikner and Kaveh Razavi reported that for Intel processors (Intel Core generation 6, 7 and 8), protections against speculative branch target injection attacks were insufficient in some circumstances, which may allow arbitrary speculative code execution under certain microarchitecture-dependent conditions. More information can be found at * [CVE-2022-36879](https://security-tracker.debian.org/tracker/CVE-2022-36879) A flaw was discovered in xfrm\_expand\_policies in the xfrm subsystem which can cause a reference count to be dropped twice. * [CVE-2022-36946](https://security-tracker.debian.org/tracker/CVE-2022-36946) Domingo Dirutigliano and Nicola Guerrera reported a memory corruption flaw in the Netfilter subsystem which may result in denial of service. For the stable distribution (bullseye), these problems have been fixed in version 5.10.136-1. We recommend that you upgrade your linux packages. For the detailed security status of linux please refer to its security tracker page at: [\ https://security-tracker.debian.org/tracker/linux](https://security-tracker.debian.org/tracker/linux)


Affected Software


CPE Name Name Version
linux 5.10.113-1
linux 5.10.127-2
linux 5.10.92-1
linux 5.10.103-1
linux 5.10.120-1~bpo10+1
linux 5.10.103-1~bpo10+1
linux 5.10.127-1
linux 5.10.127-2~bpo10+1
linux 5.10.84-1
linux 5.10.46-4
linux 5.10.120-1
linux 5.10.92-2
linux 5.10.70-1
linux 5.10.92-1~bpo10+1
linux 5.10.46-5
linux 5.10.70-1~bpo10+1
linux 5.10.106-1

Related