Lucene search

K
amazonAmazonALAS-2022-1843
HistorySep 01, 2022 - 9:09 p.m.

Important: postgresql

2022-09-0121:09:00
alas.aws.amazon.com
5
postgresql
arbitrary code execution
data confidentiality
integrity
system availability
cve-2021-32027
cve-2022-1552
cve-2023-5869

6.5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:P/I:P/A:P

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

8.5 High

AI Score

Confidence

High

0.015 Low

EPSS

Percentile

86.7%

Issue Overview:

2024-05-23: CVE-2021-32027 was added to this advisory.

2024-05-23: CVE-2023-5869 was added to this advisory.

A flaw was found in postgresql. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. (CVE-2021-32027)

A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user’s objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity. (CVE-2022-1552)

While modifying certain SQL array values, missing overflow checks let authenticated database users write arbitrary bytes to a memory area that facilitates arbitrary code execution. Missing overflow checks also let authenticated database users read a wide area of server memory. The CVE-2021-32027 fix covered some attacks of this description, but it missed others. (CVE-2023-5869)

Affected Packages:

postgresql

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update postgresql to update your system.

New Packages:

aarch64:  
    postgresql-9.2.24-8.amzn2.aarch64  
    postgresql-libs-9.2.24-8.amzn2.aarch64  
    postgresql-server-9.2.24-8.amzn2.aarch64  
    postgresql-docs-9.2.24-8.amzn2.aarch64  
    postgresql-contrib-9.2.24-8.amzn2.aarch64  
    postgresql-devel-9.2.24-8.amzn2.aarch64  
    postgresql-static-9.2.24-8.amzn2.aarch64  
    postgresql-upgrade-9.2.24-8.amzn2.aarch64  
    postgresql-plperl-9.2.24-8.amzn2.aarch64  
    postgresql-plpython-9.2.24-8.amzn2.aarch64  
    postgresql-pltcl-9.2.24-8.amzn2.aarch64  
    postgresql-test-9.2.24-8.amzn2.aarch64  
    postgresql-debuginfo-9.2.24-8.amzn2.aarch64  
  
i686:  
    postgresql-9.2.24-8.amzn2.i686  
    postgresql-libs-9.2.24-8.amzn2.i686  
    postgresql-server-9.2.24-8.amzn2.i686  
    postgresql-docs-9.2.24-8.amzn2.i686  
    postgresql-contrib-9.2.24-8.amzn2.i686  
    postgresql-devel-9.2.24-8.amzn2.i686  
    postgresql-static-9.2.24-8.amzn2.i686  
    postgresql-upgrade-9.2.24-8.amzn2.i686  
    postgresql-plperl-9.2.24-8.amzn2.i686  
    postgresql-plpython-9.2.24-8.amzn2.i686  
    postgresql-pltcl-9.2.24-8.amzn2.i686  
    postgresql-test-9.2.24-8.amzn2.i686  
    postgresql-debuginfo-9.2.24-8.amzn2.i686  
  
src:  
    postgresql-9.2.24-8.amzn2.src  
  
x86_64:  
    postgresql-9.2.24-8.amzn2.x86_64  
    postgresql-libs-9.2.24-8.amzn2.x86_64  
    postgresql-server-9.2.24-8.amzn2.x86_64  
    postgresql-docs-9.2.24-8.amzn2.x86_64  
    postgresql-contrib-9.2.24-8.amzn2.x86_64  
    postgresql-devel-9.2.24-8.amzn2.x86_64  
    postgresql-static-9.2.24-8.amzn2.x86_64  
    postgresql-upgrade-9.2.24-8.amzn2.x86_64  
    postgresql-plperl-9.2.24-8.amzn2.x86_64  
    postgresql-plpython-9.2.24-8.amzn2.x86_64  
    postgresql-pltcl-9.2.24-8.amzn2.x86_64  
    postgresql-test-9.2.24-8.amzn2.x86_64  
    postgresql-debuginfo-9.2.24-8.amzn2.x86_64  

Additional References

Red Hat: CVE-2021-32027, CVE-2022-1552, CVE-2023-5869

Mitre: CVE-2021-32027, CVE-2022-1552, CVE-2023-5869

6.5 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:S/C:P/I:P/A:P

8.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

8.5 High

AI Score

Confidence

High

0.015 Low

EPSS

Percentile

86.7%