logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2022-1552

Description

A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user's objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity.


Affected Package


OS OS Version Package Name Package Version
ubuntu upstream postgresql-10 any
ubuntu 20.04 postgresql-12 12.11-0ubuntu0.20.04.1
ubuntu upstream postgresql-12 any
ubuntu 21.10 postgresql-13 13.7-0ubuntu0.21.10.1
ubuntu upstream postgresql-13 13.7
ubuntu 22.04 postgresql-14 14.3-0ubuntu0.22.04.1
ubuntu upstream postgresql-14 14.3
ubuntu upstream postgresql-9.1 any
ubuntu upstream postgresql-9.3 any
ubuntu upstream postgresql-9.5 any
ubuntu 16.04 postgresql-9.5 9.5.25-0ubuntu0.16.04.1+esm2

Related