USN-5440-1: PostgreSQL vulnerability | Cloud Foundry


usn-5440-1 # ## Severity Medium ## Vendor Canonical Ubuntu ## Versions Affected * Canonical Ubuntu 18.04 ## Description Alexander Lakhin discovered that PostgreSQL incorrectly handled the security restricted operation sandbox when a privileged user is maintaining another user’s objects. An attacker having permission to create non-temp objects can use this issue to execute arbitrary commands as the superuser. Update Instructions: Run `sudo ua fix USN-5440-1` to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: postgresql-server-dev-10 – 10.21-0ubuntu0.18.04.1 postgresql-10 – 10.21-0ubuntu0.18.04.1 libecpg6 – 10.21-0ubuntu0.18.04.1 libpq5 – 10.21-0ubuntu0.18.04.1 libpgtypes3 – 10.21-0ubuntu0.18.04.1 postgresql-pltcl-10 – 10.21-0ubuntu0.18.04.1 postgresql-plperl-10 – 10.21-0ubuntu0.18.04.1 libecpg-dev – 10.21-0ubuntu0.18.04.1 postgresql-plpython3-10 – 10.21-0ubuntu0.18.04.1 libpq-dev – 10.21-0ubuntu0.18.04.1 postgresql-plpython-10 – 10.21-0ubuntu0.18.04.1 postgresql-doc-10 – 10.21-0ubuntu0.18.04.1 postgresql-client-10 – 10.21-0ubuntu0.18.04.1 libecpg-compat3 – 10.21-0ubuntu0.18.04.1 No subscription required CVEs contained in this USN include: CVE-2022-1552. ## Affected Cloud Foundry Products and Versions _Severity is medium unless otherwise noted._ * cflinuxfs3 * All versions prior to 0.300.0 * CF Deployment * All versions prior to 21.0.0 ## Mitigation Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases: * cflinuxfs3 * Upgrade all versions to 0.300.0 or greater * CF Deployment * Upgrade all versions to 21.0.0 or greater ## References * [USN Notice](<https://ubuntu.com/security/notices/USN-5440-1>) * [CVE-2022-1552](<https://ubuntu.com/security/CVE-2022-1552>) ## History 2022-07-28: Initial vulnerability report published.

Affected Software

CPE Name Name Version
cflinuxfs3 0.300.0
cf deployment 21.0.0