logo
DATABASE RESOURCES PRICING ABOUT US

PostgreSQL vulnerability

Description

## Releases * Ubuntu 16.04 ESM ## Packages * postgresql-9.5 \- Object-relational SQL database Alexander Lakhin discovered that PostgreSQL incorrectly handled the security restricted operation sandbox when a privileged user is maintaining another user’s objects. An attacker having permission to create non-temp objects can use this issue to execute arbitrary commands as the superuser.


Affected Package


OS OS Version Package Name Package Version
Ubuntu 16.04 postgresql-9.5 9.5.25-0ubuntu0.16.04.1+esm2 Available with Ubuntu Pro
Ubuntu 16.04 libecpg-compat3 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libecpg-compat3-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libecpg-dev 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libecpg-dev-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libecpg6 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libecpg6-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpgtypes3 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpgtypes3-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpq-dev 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpq-dev-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpq5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 libpq5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-9.5-dbg 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-client-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-client-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-contrib-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-contrib-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-doc-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plperl-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plperl-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plpython-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plpython-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plpython3-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-plpython3-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-pltcl-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-pltcl-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-server-dev-9.5 9.5.25-0ubuntu0.16.04.1+esm2
Ubuntu 16.04 postgresql-server-dev-9.5-dbgsym 9.5.25-0ubuntu0.16.04.1+esm2

Related