Lucene search

K
nessusTenable700668.PASL
HistoryMay 10, 2019 - 12:00 a.m.

Apache Tomcat 6.0.x < 6.0.48 / 7.0.x < 7.0.73 / 8.0.x < 8.0.39 Multiple Vulnerabilities

2019-05-1000:00:00
Tenable
www.tenable.com
56

According to its self-reported version number, the Apache Tomcat service running on the remote host is 6.0.x prior to 6.0.48, 7.0.x prior to 7.0.73, 8.0.x prior to 8.0.39. It is, therefore, affected by multiple vulnerabilities:

  • A flaw exists that is triggered when handling request lines containing certain invalid characters. An unauthenticated, remote attacker can exploit this, by injecting additional headers into responses, to conduct HTTP response splitting attacks. (CVE-2016-6816)

  • A remote code execution vulnerability exists in the JMX listener in JmxRemoteLifecycleListener.java due to improper deserialization of Java objects. An unauthenticated, remote attacker can exploit this to execute arbitrary code. (CVE-2016-8735)

Note that Nessus Network Monitor has not attempted to exploit these issues but has instead relied only on the application’s self-reported version number.

Binary data 700668.pasl
VendorProductVersionCPE
apachetomcatcpe:/a:apache:tomcat