logo
DATABASE RESOURCES PRICING ABOUT US

[SECURITY] [DSA 3739-1] tomcat8 security update

Description

- ------------------------------------------------------------------------- Debian Security Advisory DSA-3739-1 security@debian.org https://www.debian.org/security/ Sebastien Delafond December 18, 2016 https://www.debian.org/security/faq - ------------------------------------------------------------------------- Package : tomcat8 CVE ID : CVE-2016-6816 CVE-2016-8735 CVE-2016-9774 CVE-2016-9775 Debian Bug : 802312 845385 845393 Multiple security vulnerabilities were discovered in the Tomcat servlet and JSP engine, as well as in its Debian-specific maintainer scripts. Those flaws allowed for privilege escalation, information disclosure, and remote code execution. As part of this update, several regressions stemming from incomplete fixes for previous vulnerabilities were also fixed. For the stable distribution (jessie), these problems have been fixed in version 8.0.14-1+deb8u5. For the testing (stretch) and unstable (sid) distributions, these problems have been fixed in version 8.5.8-2. We recommend that you upgrade your tomcat8 packages. Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/ Mailing list: debian-security-announce@lists.debian.org


Affected Package


OS OS Version Package Name Package Version
Debian 7 libtomcat7-java 7.0.28-4+deb7u8
Debian 8 tomcat7-admin 7.0.56-3+deb8u6
Debian 7 libservlet3.0-java-doc 7.0.28-4+deb7u7
Debian 7 tomcat6-extras 6.0.45+dfsg-1~deb7u3
Debian 8 tomcat8-admin 8.0.14-1+deb8u5
Debian 7 tomcat6-examples 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat6 6.0.45+dfsg-1~deb7u4
Debian 7 tomcat7-user 7.0.28-4+deb7u7
Debian 8 libservlet3.0-java 7.0.56-3+deb8u6
Debian 7 tomcat6-admin 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat6-common 6.0.45+dfsg-1~deb7u4
Debian 7 libtomcat6-java 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat7-examples 7.0.28-4+deb7u8
Debian 7 tomcat6-user 6.0.45+dfsg-1~deb7u4
Debian 7 tomcat7-user 7.0.28-4+deb7u8
Debian 7 libservlet2.4-java 6.0.45+dfsg-1~deb7u4
Debian 8 libservlet3.1-java-doc 8.0.14-1+deb8u5
Debian 8 libservlet3.1-java 8.0.14-1+deb8u5
Debian 7 libservlet3.0-java 7.0.28-4+deb7u8
Debian 7 tomcat6-common 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat7-common 7.0.28-4+deb7u8
Debian 7 libservlet2.5-java 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat6 6.0.45+dfsg-1~deb7u3
Debian 8 tomcat8-docs 8.0.14-1+deb8u5
Debian 7 tomcat6-docs 6.0.45+dfsg-1~deb7u3
Debian 8 tomcat8 8.0.14-1+deb8u5
Debian 7 libservlet2.5-java-doc 6.0.45+dfsg-1~deb7u3
Debian 7 libservlet2.4-java 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat6-extras 6.0.45+dfsg-1~deb7u4
Debian 7 tomcat7-docs 7.0.28-4+deb7u8
Debian 8 tomcat7-docs 7.0.56-3+deb8u6
Debian 8 tomcat7-user 7.0.56-3+deb8u6
Debian 7 tomcat7 7.0.28-4+deb7u7
Debian 8 tomcat8-examples 8.0.14-1+deb8u5
Debian 7 libtomcat7-java 7.0.28-4+deb7u7
Debian 7 libservlet2.5-java 6.0.45+dfsg-1~deb7u4
Debian 7 libservlet3.0-java-doc 7.0.28-4+deb7u8
Debian 7 tomcat6-examples 6.0.45+dfsg-1~deb7u4
Debian 8 tomcat7-common 7.0.56-3+deb8u6
Debian 7 tomcat7-examples 7.0.28-4+deb7u7
Debian 7 tomcat6-user 6.0.45+dfsg-1~deb7u3
Debian 7 tomcat6-admin 6.0.45+dfsg-1~deb7u4
Debian 7 tomcat7-admin 7.0.28-4+deb7u8
Debian 8 tomcat7 7.0.56-3+deb8u6
Debian 8 libtomcat7-java 7.0.56-3+deb8u6
Debian 7 tomcat7-common 7.0.28-4+deb7u7
Debian 7 tomcat7-admin 7.0.28-4+deb7u7
Debian 8 tomcat7-examples 7.0.56-3+deb8u6
Debian 7 libtomcat6-java 6.0.45+dfsg-1~deb7u4
Debian 8 libtomcat8-java 8.0.14-1+deb8u5
Debian 8 tomcat8-common 8.0.14-1+deb8u5
Debian 7 tomcat7 7.0.28-4+deb7u8
Debian 7 libservlet3.0-java 7.0.28-4+deb7u7
Debian 7 tomcat6-docs 6.0.45+dfsg-1~deb7u4
Debian 8 tomcat8-user 8.0.14-1+deb8u5
Debian 8 libservlet3.0-java-doc 7.0.56-3+deb8u6
Debian 7 tomcat7-docs 7.0.28-4+deb7u7
Debian 7 libservlet2.5-java-doc 6.0.45+dfsg-1~deb7u4

Related