Lucene search

K
cvelistApacheCVELIST:CVE-2016-6816
HistoryMar 20, 2017 - 6:00 p.m.

CVE-2016-6816

2017-03-2018:00:00
apache
www.cve.org
4

AI Score

8

Confidence

High

EPSS

0.003

Percentile

66.0%

The code in Apache Tomcat 9.0.0.M1 to 9.0.0.M11, 8.5.0 to 8.5.6, 8.0.0.RC1 to 8.0.38, 7.0.0 to 7.0.72, and 6.0.0 to 6.0.47 that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack and/or obtain sensitive information from requests other then their own.

CNA Affected

[
  {
    "product": "Apache Tomcat",
    "vendor": "Apache Software Foundation",
    "versions": [
      {
        "status": "affected",
        "version": "9.0.0.M1 to 9.0.0.M11"
      },
      {
        "status": "affected",
        "version": "8.5.0 to 8.5.6"
      },
      {
        "status": "affected",
        "version": "8.0.0.RC1 to 8.0.38"
      },
      {
        "status": "affected",
        "version": "7.0.0 to 7.0.72"
      },
      {
        "status": "affected",
        "version": "6.0.0 to 6.0.47"
      },
      {
        "status": "affected",
        "version": "Earlier, unsupported versions may also be affected."
      }
    ]
  }
]

References