logo
DATABASE RESOURCES PRICING ABOUT US

gnutls -- possible overflow/Denial of service vulnerabilities

Description

Mu Dynamics, Inc. reports: The block cipher decryption logic in GnuTLS assumed that a record containing any data which was a multiple of the block size was valid for further decryption processing, leading to a heap corruption vulnerability.


Affected Package


OS OS Version Package Name Package Version
FreeBSD any gnutls 2.12.18
FreeBSD any gnutls-devel 3.0.15

Related