Lucene search

K
ubuntucveUbuntu.comUB:CVE-2019-13638
HistoryJul 22, 2019 - 12:00 a.m.

CVE-2019-13638

2019-07-2200:00:00
ubuntu.com
ubuntu.com
6

0.004 Low

EPSS

Percentile

73.2%

GNU patch through 2.7.6 is vulnerable to OS shell command injection that
can be exploited by opening a crafted patch file that contains an ed style
diff payload with shell metacharacters. The ed editor does not need to be
present on the vulnerable system. This is different from CVE-2018-1000156.

Bugs

OSVersionArchitecturePackageVersionFilename
ubuntu18.04noarchpatch< 2.7.6-2ubuntu1.1UNKNOWN
ubuntu19.04noarchpatch< 2.7.6-3ubuntu0.1UNKNOWN
ubuntu14.04noarchpatch< 2.7.1-4ubuntu2.4+esm1) Available with Ubuntu Pro or Ubuntu Pro (Infra-onlyUNKNOWN
ubuntu16.04noarchpatch< 2.7.5-1ubuntu0.16.04.2UNKNOWN