Lucene search

K
suse
SuseOPENSUSE-SU-2020:1806-1
HistoryNov 01, 2020 - 12:00 a.m.

Security update for phpMyAdmin (important)

2020-11-0100:00:00
lists.opensuse.org
38

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

7.5 High

CVSS2

Access Vector

NETWORK

Access Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

An update that solves 5 vulnerabilities and has one errata
is now available.

Description:

This update for phpMyAdmin fixes the following issues:

phpMyAdmin was updated to 4.9.7 (boo#1177842):
* Fix two factor authentication that was broken in 4.9.6
* Fix incompatibilities with older PHP versions

Update to 4.9.6:

  • Fixed XSS relating to the transformation feature (boo#1177561
    CVE-2020-26934, PMASA-2020-5)
  • Fixed SQL injection vulnerability in SearchController (boo#1177562
    CVE-2020-26935, PMASA-2020-6)

Update to 4.9.5:

This is a security release containing several bug fixes.

 * CVE-2020-10804: SQL injection vulnerability in the user accounts page,
   particularly when changing a password (boo#1167335, PMASA-2020-2)
 * CVE-2020-10802: SQL injection vulnerability relating to the search
   feature (boo#1167336, PMASA-2020-3)
 * CVE-2020-10803: SQL injection and XSS having to do with displaying
   results (boo#1167337, PMASA-2020-4)
 * Removing of the "options" field for the external transformation.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or β€œzypper patch”.

Alternatively you can run the command listed for your product:

  • openSUSE Leap 15.1:

    zypper in -t patch openSUSE-2020-1806=1

  • openSUSE Backports SLE-15-SP1:

    zypper in -t patch openSUSE-2020-1806=1

  • openSUSE Backports SLE-15:

    zypper in -t patch openSUSE-2020-1806=1

  • SUSE Package Hub for SUSE Linux Enterprise 12:

    zypper in -t patch openSUSE-2020-1806=1

How to protect your server from attacks?

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

7.5 High

CVSS2

Access Vector

NETWORK

Access Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

Related for OPENSUSE-SU-2020:1806-1