SQL injection relating to searching

2020-03-20T00:00:00
ID PHPMYADMIN:PMASA-2020-3
Type phpmyadmin
Reporter phpMyAdmin
Modified 2020-03-22T00:00:00

Description

PMASA-2020-3

Announcement-ID: PMASA-2020-3

Date: 2020-03-20

Updated: 2020-03-22

Summary

SQL injection relating to searching

Description

An SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions within phpMyAdmin.

An attacker can generate specially-crafted database or table names. The attack can be performed if a user attempts certain search operations on the malicious database or table.

Severity

Because of the specific steps required to exploit this, we consider this vulnerability to be of moderate severity.

Affected Versions

phpMyAdmin 4.9.x releases prior to 4.9.5 and the 5.0.x releases prior to 5.0.2 are affected.

Solution

Upgrade to phpMyAdmin 4.9.5 or 5.0.2 or newer or apply patch listed below.

References

Thanks to hoangn144_VCS and Yutaka WATANABE for reporting these vulnerabilities.

Assigned CVE ids: CVE-2020-10802

CWE ids: CWE-661

Patches

The following commits have been made to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.