Security update for libarchive (moderate)

2019-04-12T12:42:07
ID OPENSUSE-SU-2019:1196-1
Type suse
Reporter Suse
Modified 2019-04-12T12:42:07

Description

This update for libarchive fixes the following issues:

Security issues fixed:

  • CVE-2018-1000877: Fixed a double free vulnerability in RAR decoder (bsc#1120653)
  • CVE-2018-1000878: Fixed a Use-After-Free vulnerability in RAR decoder (bsc#1120654)
  • CVE-2018-1000879: Fixed a NULL Pointer Dereference vulnerability in ACL parser (bsc#1120656)
  • CVE-2018-1000880: Fixed an Improper Input Validation vulnerability in WARC parser (bsc#1120659)
  • CVE-2019-1000019: Fixed an Out-Of-Bounds Read vulnerability in 7zip decompression (bsc#1124341)
  • CVE-2019-1000020: Fixed an Infinite Loop vulnerability in ISO9660 parser (bsc#1124342)

This update was imported from the SUSE:SLE-15:Update update project.