[SECURITY] [DLA 1612-1] libarchive security update

2018-12-21T22:54:23
ID DEBIAN:DLA-1612-1:FCCC2
Type debian
Reporter Debian
Modified 2018-12-21T22:54:23

Description

Package : libarchive Version : 3.1.2-11+deb8u6 CVE ID : CVE-2018-1000877 CVE-2018-1000878 Debian Bug : 916964 916963

Daniel Axtens discovered a double-free and use-after-free vulnerability in libarchive's RAR decoder that can result in a denial-of-service (application crash) or may have other unspecified impact when a malformed RAR archive is processed.

For Debian 8 "Jessie", these problems have been fixed in version 3.1.2-11+deb8u6.

We recommend that you upgrade your libarchive packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS