[SECURITY] [DSA 3017-1] php-cas security update

2014-10-15T00:00:00
ID SECURITYVULNS:DOC:31226
Type securityvulns
Reporter Securityvulns
Modified 2014-10-15T00:00:00

Description

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1


Debian Security Advisory DSA-3017-1 security@debian.org http://www.debian.org/security/ Thijs Kinkhorst
September 2, 2014 http://www.debian.org/security/faq


Package : php-cas CVE ID : CVE-2014-4172 Debian Bug : 759718

Marvin S. Addison discovered that Jasig phpCAS, a PHP library for the CAS authentication protocol, did not encode tickets before adding them to an URL, creating a possibility for cross site scripting.

For the stable distribution (wheezy), this problem has been fixed in version 1.3.1-4+deb7u1.

The unstable distribution (sid) will be fixed soon.

We recommend that you upgrade your php-cas packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org -----BEGIN PGP SIGNATURE----- Version: GnuPG v1

iQEcBAEBAgAGBQJUBfLYAAoJEFb2GnlAHawEPTQIAJqk7ssQH8+kRu82vo+nQn+k bXL8oVfaFOszBtuxyi3b2pfIkcysMJK8ynpHTpJZKziO7ECxzBArhhv+i71vkNBm 3UmDgMY9Gg17YV3Si0UP+barEG7HstNHWvCXKtDmQxlRR46b0Bt4DO5yx6naSZ+S Ka9TagRcQmMT3t4jtRvAUW6Qe5nyve/uhuOkW0NJU/hJFDlJ0UgYxknwwpaJ7wFQ ha/mKW7eFWMPHezeUDC5agdl3hdmn00bYPwMOQytSaL1Ydt6Qmhou3V9RZL1BopF de3voyjGfOEHimtOCKNnmR7uc230Dvwq1nsCyqMHxAwilupYnEh9srG52S72KUM= =S625 -----END PGP SIGNATURE-----