[SA18077] Macromedia JRun Server Two Vulnerabilities

2005-12-20T00:00:00
ID SECURITYVULNS:DOC:10746
Type securityvulns
Reporter Securityvulns
Modified 2005-12-20T00:00:00

Description

TITLE: Macromedia JRun Server Two Vulnerabilities

SECUNIA ADVISORY ID: SA18077

VERIFY ADVISORY: http://secunia.com/advisories/18077/

CRITICAL: Moderately critical

IMPACT: Exposure of sensitive information, DoS

WHERE: >From remote

SOFTWARE: Macromedia Jrun 4.x http://secunia.com/product/863/

DESCRIPTION: Two vulnerabilities have been reported in Macromedia JRun Server, which can be exploited by malicious people to disclose potentially sensitive information and to cause a DoS (Denial of Service).

1) An error in URL parsing can be exploited to view the source code of files on the server via specially crafted requests.

The vulnerability may be related to #3 in: SA12638

2) An error exists in the JWS (JRun Web Server) when handling long URLs and headers. This can be exploited to cause a DoS.

The vulnerabilities have been reported in JRun 4.0 (all editions).

SOLUTION: Install JRun 4.0 Updater 6. http://www.macromedia.com/support/jrun/updaters.html

The vendor does not recommend the use of JWS as a production web server.

PROVIDED AND/OR DISCOVERED BY: 1) Alex Daley 2) iDEFENSE

ORIGINAL ADVISORY: http://www.macromedia.com/devnet/security/security_zone/mpsb05-13.html

OTHER REFERENCES: SA12638: http://secunia.com/advisories/12638/


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.