596 matches found
WordPress WP Scraper plugin <= 5.7 - Missing Authorization to Arbitrary Page/Post Creation vulnerability
Missing Authorization to Arbitrary Page/Post Creation vulnerability discovered by Lucio Sá in WordPress Plugin WP Scraper versions = 5.7...
CVE-2024-3663: Missing Authorization
The WP Scraper plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the wpscrapermultiscrapeaction function in all versions up to, and including, 5.7. This makes it possible for authenticated attackers, with subscriber-level access and above, to create...
WordPress WP Scraper Plugin <= 5.7 is vulnerable to Broken Access Control
Software WP Scraper Type Plugin Vulnerable versions = 5.7 Fixed in 5.8 OWASP Top 10 A5: Broken Access Control Classification Broken Access Control CVE CVE-2024-3663 Patch priority Low CVSS severity Low 4.3 Developer Claim ownership PSID 6a3b87c193df Credits Lucio Sá Required privilege Subscriber...
WordPress Plugin WP Scraper security vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a set of blogging platforms developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A security...
scraper-factory (>=0.1.0, <=0.2.1) potentially affected by CVE-2024-1968 via scrapy (1.7.2)
scrapy PYPI version 1.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - scraper-factory =0.1.0, =0.2.1 Source cves: CVE-2024-1968 Source advisory: OSV:PYSEC-2024-258...
scraper-factory (>=0.1.0, <=0.2.1) potentially affected by unknown CVE via scrapy (1.7.2)
scrapy PYPI version 1.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - scraper-factory =0.1.0, =0.2.1 Source cves: unknown CVE Source advisory: OSV:GHSA-23J4-MW76-5V7H...
scraper-factory (>=0.1.0, <=0.2.1) potentially affected by unknown CVE via scrapy (1.7.2)
scrapy PYPI version 1.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - scraper-factory =0.1.0, =0.2.1 Source cves: unknown CVE Source advisory: OSV:GHSA-JM3V-QXMH-HXWV...
scraper-factory (>=0.1.0, <=0.2.1) potentially affected by CVE-2024-1968 via scrapy (1.7.2)
scrapy PYPI version 1.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - scraper-factory =0.1.0, =0.2.1 Source cves: CVE-2024-1968 Source advisory: OSV:GHSA-4QQQ-9VQF-3H3F...
CVE-2024-24786 vulnerabilities
Vulnerabilities for packages: k8sgpt, osv-scanner, kubernetes-csi-external-provisioner, temporal-server-fips, zarf, falcoctl-fips, pgpool2exporter-fips, k9s, pulumi-language-dotnet, kustomize, oauth2-proxy, secrets-store-csi-driver-provider-azure, prometheus-alertmanager, influx,...
scraper-factory (>=0.1.0, <=0.2.1) potentially affected by CVE-2024-1892 via scrapy (1.7.2)
scrapy PYPI version 1.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - scraper-factory =0.1.0, =0.2.1 Source cves: CVE-2024-1892 Source advisory: OSV:PYSEC-2024-162...
CVE-2024-0455
The inclusion of the web scraper for AnythingLLM means that any user with the proper authorization level manager, admin, and when in single user could put in the URL http://169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance which is a special IP and URL th...
Cross site request forgery (csrf)
The inclusion of the web scraper for AnythingLLM means that any user with the proper authorization level manager, admin, and when in single user could put in the URL http://169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance which is a special IP and URL th...
CVE-2024-0455 SSRF on AWS deployed instances of AnythingLLM via /metadata
The inclusion of the web scraper for AnythingLLM means that any user with the proper authorization level manager, admin, and when in single user could put in the URL http://169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance which is a special IP and URL th...
CVE-2024-0455
CVE-2024-0455 concerns AnythingLLM where a web scraper can trigger a server-side request to the AWS EC2 metadata URL 169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance. If accessed by a user with manager/admin permissions (and in single-user mode) from wit...
CVE-2024-0455 SSRF on AWS deployed instances of AnythingLLM via /metadata
The inclusion of the web scraper for AnythingLLM means that any user with the proper authorization level manager, admin, and when in single user could put in the URL http://169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance which is a special IP and URL th...
PT-2024-15574 · Unknown · Anything-Llm
Name of the Vulnerable Software and Affected Versions: AnythingLLM affected versions not specified Description: The issue allows users with proper authorization levels manager, admin, and when in single user mode to access sensitive information by using a web scraper to query a specific URL:...
CVE-2024-0455: Server-Side Request Forgery (SSRF)
The inclusion of the web scraper for AnythingLLM means that any user with the proper authorization level manager, admin, and when in single user could put in the URL http://169.254.169.254/latest/meta-data/identity-credentials/ec2/security-credentials/ec2-instance which is a special IP and URL th...
dcicsnovault (>=2.0.0b4, <=4.0.0b2), django-dynamic-scraper (>=0.11.4, <=0.13.1) +12 more potentially affected by CVE-2023-50447 via pillow (3.4.2)
pillow PYPI version 3.4.2 is affected by a known vulnerability. The following packages have a transitive dependency on pillow and may be impacted: - dcicsnovault =2.0.0b4, =0.11.4, =0.18.1, =0.6.12a2, =0.9.0, =0.2.1, =0.0.3, =1.6.0, =1.4.0, =1.12.0 - yulelog 0.0.3 Source cves: CVE-2023-50447 Sour...
CVE-2023-48699 fastbots Eval Injection vulnerability
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model POM design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability ...
dcicsnovault (>=2.0.0b4, <=4.0.0b2), django-dynamic-scraper (>=0.11.4, <=0.13.1) +12 more potentially affected by CVE-2023-44271 via pillow (3.4.2)
pillow PYPI version 3.4.2 is affected by a known vulnerability. The following packages have a transitive dependency on pillow and may be impacted: - dcicsnovault =2.0.0b4, =0.11.4, =0.18.1, =0.6.12a2, =0.9.0, =0.2.1, =0.0.3, =1.6.0, =1.4.0, =1.12.0 - yulelog 0.0.3 Source cves: CVE-2023-44271 Sour...