133 matches found
CVE-2021-43857
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
CVE-2021-43857
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
CVE-2021-43857
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
Remote code execution
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
PYSEC-2021-867
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
PYSEC-2021-867
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
CVE-2021-43857 Gerapy may contain remote code execution vulnerability
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
CVE-2021-43857
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
CVE-2021-43857
CVE-2021-43857 affects Gerapy, a distributed crawler management framework. Affected versions prior to 0.9.8 are vulnerable to remote code execution due to an OS command injection flaw in the spider/config flow. The issue is patched in version 0.9.8; users should upgrade to 0.9.8 or later to mitig...
CVE-2021-43857: Improper Neutralization of Special Elements used in an OS Command
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8...
PT-2021-23983
Name of the Vulnerable Software and Affected Versions: Gerapy versions prior to 0.9.8 Description: Gerapy is a distributed crawler management framework. The issue allows for remote code execution. The project configure function is affected. Recommendations: For Gerapy versions prior to 0.9.8,...
Gerapy operating system command injection vulnerability
Gerapy is a distributed crawler management framework based on Scrapy, Scrapyd, Django and Vue.js. An operating system command injection vulnerability exists in versions prior to Gerapy 0.9.8, which stems from the software's lack of effective filtering and escaping of system commands, resulting in...
Gerapy Authentication Remote Command Execution Vulnerability
Gerapy is a crawler framework based on the Scrapy Scrapyd Scrapyd Client Scrapyd API Django. Gerapy authenticates remote command execution vulnerabilities, which can be exploited by attackers to gain control of the server...
gerapy (>=0.8.5rc2, <=0.9.3), scrapy-plus (1.0.5) +2 more potentially affected by CVE-2021-41124 via scrapy-splash (0.7.2)
scrapy-splash PYPI version 0.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy-splash and may be impacted: - gerapy =0.8.5rc2, =1.1.0, =3.2.2, =3.5.0 Source cves: CVE-2021-41124 Source advisory: OSV:GHSA-823F-CWM9-4G74...
gerapy (>=0.8.5rc2, <=0.9.3), scrapy-plus (1.0.5) +2 more potentially affected by CVE-2021-41124 via scrapy-splash (0.7.2)
scrapy-splash PYPI version 0.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy-splash and may be impacted: - gerapy =0.8.5rc2, =1.1.0, =3.2.2, =3.5.0 Source cves: CVE-2021-41124 Source advisory: GHSA-823F-CWM9-4G74...
gerapy (>=0.8.5rc2, <=0.9.3), scrapy-plus (1.0.5) +2 more potentially affected by CVE-2021-41124 via scrapy-splash (0.7.2)
scrapy-splash PYPI version 0.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy-splash and may be impacted: - gerapy =0.8.5rc2, =1.1.0, =3.2.2, =3.5.0 Source cves: CVE-2021-41124 Source advisory: OSV:PYSEC-2021-364...
gerapy (>=0.8.5rc2, <=0.9.3), scrapy-plus (1.0.5) +2 more potentially affected by CVE-2021-41124 via scrapy-splash (0.7.2)
scrapy-splash PYPI version 0.7.2 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy-splash and may be impacted: - gerapy =0.8.5rc2, =1.1.0, =3.2.2, =3.5.0 Source cves: CVE-2021-41124 Source advisory: MEND:CVE-2021-41124...
gerapy (>=0.8.7, <=0.9.3a2), ora2 (2.4.4) potentially affected by CVE-2021-33203 via django (1.11.26)
django PYPI version 1.11.26 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - gerapy =0.8.7, =0.9.3a2 - ora2 2.4.4 Source cves: CVE-2021-33203 Source advisory: OSV:GHSA-68W8-QJQ3-2GFM...
gerapy (>=0.8.7, <=0.9.3a2), ora2 (2.4.4) potentially affected by CVE-2021-33203 via django (1.11.26)
django PYPI version 1.11.26 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - gerapy =0.8.7, =0.9.3a2 - ora2 2.4.4 Source cves: CVE-2021-33203 Source advisory: OSV:PYSEC-2021-98...
Command injection in Gerapy
This affects the package Gerapy from 0 and before 0.9.3. The input being passed to Popen, via the projectconfigure endpoint, isn’t being sanitized...