6145 matches found
net.mingsoft:ms-mattention (1.0.2), net.mingsoft:ms-mcomment (1.0.1) +4 more potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.8)
net.mingsoft:ms-basic MAVEN version 1.0.8 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mattention 1.0.2 - net.mingsoft:ms-mcomment 1.0.1 - net.mingsoft:ms-mdiy 1.0.7 - net.mingsoft:ms-mpay...
net.mingsoft:ms-upgrader (>=1.0.6, <=1.0.10) potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.10)
net.mingsoft:ms-basic MAVEN version 1.0.10 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-upgrader =1.0.6, =1.0.10 Source cves: CVE-2024-33748 Source advisory: OSV:GHSA-64CM-3CJ3-67HF...
net.mingsoft:ms-mcms (4.6.5), net.mingsoft:ms-mdiy (1.0.6) +1 more potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.7)
net.mingsoft:ms-basic MAVEN version 1.0.7 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mcms 4.6.5 - net.mingsoft:ms-mdiy 1.0.6 - net.mingsoft:ms-mpeople 1.0.6 Source cves: CVE-2024-33748...
net.mingsoft:ms-mcms (4.7.1) potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.11)
net.mingsoft:ms-basic MAVEN version 1.0.11 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mcms 4.7.1 Source cves: CVE-2024-33748 Source advisory: OSV:GHSA-64CM-3CJ3-67HF...
net.mingsoft:ms-mcms (4.7.2), net.mingsoft:ms-upgrader (1.0.13) potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.16)
net.mingsoft:ms-basic MAVEN version 1.0.16 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mcms 4.7.2 - net.mingsoft:ms-upgrader 1.0.13 Source cves: CVE-2024-33748 Source advisory:...
net.mingsoft:ms-ad (1.0.0), net.mingsoft:ms-clean (>=1.0.0, <=1.0.1) +16 more potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.20)
net.mingsoft:ms-basic MAVEN version 1.0.20 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-ad 1.0.0 - net.mingsoft:ms-clean =1.0.0, =1.0.2, =1.0.1, =1.0.8, =1.0.9 - net.mingsoft:ms-msso-clien...
net.mingsoft:ms-mcms (5.2), net.mingsoft:ms-mpeople (1.0.29) +1 more potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.32)
net.mingsoft:ms-basic MAVEN version 1.0.32 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mcms 5.2 - net.mingsoft:ms-mpeople 1.0.29 - net.mingsoft:ms-msend 1.0.12 Source cves: CVE-2024-33748...
net.mingsoft:ms-mcms (5.2.0), net.mingsoft:ms-mdiy (1.0.24) +3 more potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.33)
net.mingsoft:ms-basic MAVEN version 1.0.33 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mcms 5.2.0 - net.mingsoft:ms-mdiy 1.0.24 - net.mingsoft:ms-mpeople 1.0.30 - net.mingsoft:ms-msend...
net.mingsoft:ms-mdiy (>=1.0.25, <=1.0.26), net.mingsoft:ms-mpeople (1.0.31) potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.34)
net.mingsoft:ms-basic MAVEN version 1.0.34 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mdiy =1.0.25, =1.0.26 - net.mingsoft:ms-mpeople 1.0.31 Source cves: CVE-2024-33748 Source advisory:...
net.mingsoft:ms-mdiy (1.0.29), net.mingsoft:store-client (5.2.1) potentially affected by CVE-2024-33748 via net.mingsoft:ms-basic (1.0.38)
net.mingsoft:ms-basic MAVEN version 1.0.38 is affected by a known vulnerability. The following packages have a transitive dependency on net.mingsoft:ms-basic and may be impacted: - net.mingsoft:ms-mdiy 1.0.29 - net.mingsoft:store-client 5.2.1 Source cves: CVE-2024-33748 Source advisory:...
CVE-2024-33748
Cross-site scripting XSS vulnerability in the search function in Maven net.mingsoft MS Basic 2.1.13.4 and earlier...
PT-2024-25461 · Unknown · Mvnrepository Ms Basic +1
Name of the Vulnerable Software and Affected Versions: MvnRepository MS Basic versions 2.1.18.3 and earlier Maven net.mingsoft MS Basic versions 2.1.13.4 and earlier Description: The issue is related to a cross-site scripting XSS vulnerability in the search function. This type of vulnerability...
CVE-2024-33748: Improper Neutralization of Input During Web Page Generation
Cross-site scripting XSS vulnerability in the search function in Maven net.mingsoft MS Basic 2.1.13.4 and earlier...
CVE-2024-33748
The Maven net.mingsoft MS Basic library (versions 2.1.13.4 and earlier ) is vulnerable to a Cross-site Scripting (XSS) vulnerability within its search function . The root cause is insufficient input sanitization , which allows attackers to inject malicious scripts into the search input. This coul...
CVE-2024-33748
Cross-site scripting XSS vulnerability in the search function in Maven net.mingsoft MS Basic 2.1.13.4 and earlier...
CVE-2024-33748
Cross-site scripting XSS vulnerability in the search function in Maven net.mingsoft MS Basic 2.1.13.4 and earlier...
MvnRepository MS Basic security vulnerabilities
MvnRepository MS Basic is an application from MvnRepository, Inc. A security vulnerability exists in MvnRepository MS Basic version 2.1.18.3 and prior versions, which stems from a cross-site scripting XSS vulnerability in the search function...
WordPress Simple Basic Contact Form Plugin <= 20221201 is vulnerable to Cross Site Scripting (XSS)
Software Simple Basic Contact Form Type Plugin Vulnerable versions = 20221201 Fixed in 20240502 OWASP Top 10 A7: Cross-Site Scripting XSS Classification Cross Site Scripting XSS CVE CVE-2024-4150 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID 56d60208321f Credits...
org.jenkins-ci.plugins.workflow:workflow-basic-steps (>=1017.vb_45b_302f0cea, <=1058.vcb_fc1e3a_21a_9), org.jenkins-ci.plugins.workflow:workflow-durable-task-step (>=1246.v5524618ea_097, <=1247.v7f9dfea_b_4fd0) potentially affected by CVE-2024-34145 via org.jenkins-ci.plugins:script-security (1189.vb_a_b_7c8fd5fde)
org.jenkins-ci.plugins:script-security MAVEN version 1189.vbab7c8fd5fde is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins.workflow:workflow-basic-steps...
org.jenkins-ci.plugins.workflow:workflow-basic-steps (>=1017.vb_45b_302f0cea, <=1058.vcb_fc1e3a_21a_9), org.jenkins-ci.plugins.workflow:workflow-durable-task-step (>=1246.v5524618ea_097, <=1247.v7f9dfea_b_4fd0) potentially affected by CVE-2024-34144 via org.jenkins-ci.plugins:script-security (1189.vb_a_b_7c8fd5fde)
org.jenkins-ci.plugins:script-security MAVEN version 1189.vbab7c8fd5fde is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.plugins:script-security and may be impacted: - org.jenkins-ci.plugins.workflow:workflow-basic-steps...