logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2020-15169

Description

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.


Affected Package


OS OS Version Package Name Package Version
Debian 12 rails 2:6.1.4.7+dfsg-2
Debian 11 rails 2:6.0.3.7+dfsg-2
Debian 10 rails 2:5.2.2.1+dfsg-1+deb10u3
Debian 999 rails 2:6.1.4.7+dfsg-2

Related