logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2020-15169

Description

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.


Affected Software


CPE Name Name Version
action_view_project:action_view action view project action view 5.2.4.4
action_view_project:action_view action view project action view 6.0.3.3
debian:debian_linux debian debian linux 10.0
fedoraproject:fedora fedoraproject fedora 33

Related