[SECURITY] [DLA 679-1] qemu-kvm security update

2016-10-25T20:22:31
ID DEBIAN:DLA-679-1:C7A89
Type debian
Reporter Debian
Modified 2016-10-25T20:22:31

Description

Package : qemu-kvm Version : 1.1.2+dfsg-6+deb7u17 CVE ID : CVE-2016-8576 CVE-2016-8577 CVE-2016-8578 CVE-2016-8669

Multiple vulnerabilities have been found in qemu-kvm:

CVE-2016-8576

qemu-kvm built with the USB xHCI controller emulation support is vulnerable
to an infinite loop issue. It could occur while processing USB command ring
in 'xhci_ring_fetch'.

CVE-2016-8577

qemu-kvm built with the virtio-9p back-end support is vulnerable to a memory
leakage issue. It could occur while doing a I/O read operation in
v9fs_read() routine.

CVE-2016-8578

qemu-kvm built with the virtio-9p back-end support is vulnerable to a null
pointer dereference issue. It could occur while doing an I/O vector
unmarshalling operation in v9fs_iov_vunmarshal() routine.

CVE-2016-8669

qemu-kvm built with the 16550A UART emulation support is vulnerable to a
divide by zero issue. It could occur while updating serial device parameters
in 'serial_update_parameters'.

For Debian 7 "Wheezy", these problems have been fixed in version 1.1.2+dfsg-6+deb7u17.

We recommend that you upgrade your qemu-kvm packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS