Lucene search

K
amazonAmazonALAS2-2023-2107
HistoryJun 21, 2023 - 7:11 p.m.

Medium: glib2

2023-06-2119:11:00
alas.aws.amazon.com
8
pcre character class
glib2 security
remote code execution
integer overflow
denial of service
amazon linux 2
update
red hat
mitre

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.8 High

AI Score

Confidence

High

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.038 Low

EPSS

Percentile

91.9%

Issue Overview:

PCRE before 8.38 mishandles the [: and \ substrings in character classes, which allows remote attackers to cause a denial of service (uninitialized memory read) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror. (CVE-2015-8390)

PCRE before 8.38 mishandles the (?(<digits>) and (?(R<digits>) conditions, which allows remote attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror. (CVE-2015-8394)

Affected Packages:

glib2

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update glib2 to update your system.

New Packages:

aarch64:  
    glib2-2.56.1-9.amzn2.0.6.aarch64  
    glib2-devel-2.56.1-9.amzn2.0.6.aarch64  
    glib2-fam-2.56.1-9.amzn2.0.6.aarch64  
    glib2-static-2.56.1-9.amzn2.0.6.aarch64  
    glib2-tests-2.56.1-9.amzn2.0.6.aarch64  
    glib2-debuginfo-2.56.1-9.amzn2.0.6.aarch64  
  
i686:  
    glib2-2.56.1-9.amzn2.0.6.i686  
    glib2-devel-2.56.1-9.amzn2.0.6.i686  
    glib2-fam-2.56.1-9.amzn2.0.6.i686  
    glib2-static-2.56.1-9.amzn2.0.6.i686  
    glib2-tests-2.56.1-9.amzn2.0.6.i686  
    glib2-debuginfo-2.56.1-9.amzn2.0.6.i686  
  
noarch:  
    glib2-doc-2.56.1-9.amzn2.0.6.noarch  
  
src:  
    glib2-2.56.1-9.amzn2.0.6.src  
  
x86_64:  
    glib2-2.56.1-9.amzn2.0.6.x86_64  
    glib2-devel-2.56.1-9.amzn2.0.6.x86_64  
    glib2-fam-2.56.1-9.amzn2.0.6.x86_64  
    glib2-static-2.56.1-9.amzn2.0.6.x86_64  
    glib2-tests-2.56.1-9.amzn2.0.6.x86_64  
    glib2-debuginfo-2.56.1-9.amzn2.0.6.x86_64  

Additional References

Red Hat: CVE-2015-8390, CVE-2015-8394

Mitre: CVE-2015-8390, CVE-2015-8394

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.8 High

AI Score

Confidence

High

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.038 Low

EPSS

Percentile

91.9%