libpcre: Multiple Vulnerabilities

2016-07-09T00:00:00
ID GLSA-201607-02
Type gentoo
Reporter Gentoo Foundation
Modified 2016-07-09T00:00:00

Description

Background

libpcre is a library providing functions for Perl-compatible regular expressions.

Description

Multiple vulnerabilities have been discovered in libpcre. Please review the CVE identifiers referenced below for details.

Impact

An attacker can possibly execute arbitrary code or create a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All libpcre users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-8.38-r1"