PCRE Regular Expression Compilation Stack Buffer Overflow Remote Code Execution Vulnerability

2016-08-17T00:00:00
ID ZDI-16-477
Type zdi
Reporter Wei Lei Peng Haoxiang and Liu Yang of Nanyang Technological University
Modified 2016-06-22T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of PCRE. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the compilation of regular expressions. The issue lies in the failure to validate that compilation of sub-groups will occur within the bounds of a fixed-size stack buffer. An attacker can leverage this vulnerability to execute code within the context of the current process.