Apple OS X IOPMrootDomain Memory Corruption Privilege Escalation Vulnerability

2016-07-20T00:00:00
ID ZDI-16-436
Type zdi
Reporter Ju Zhu of Trend Micro
Modified 2016-11-09T00:00:00

Description

This vulnerability allows local attackers to execute arbitrary code on vulnerable installations of Apple OS X. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within IOPMrootDomain. By publishing to this service, an attacker can cause memory corruption. An attacker could leverage this vulnerability to execute arbitrary code with kernel privileges.