Samba lsa_io_trans_names Heap Overflow Vulnerability

2007-07-11T00:00:00
ID ZDI-07-033
Type zdi
Reporter Anonymous
Modified 2007-11-09T00:00:00

Description

This vulnerability allows attackers to execute arbitrary code on vulnerable installations of Samba. User interaction is not required to exploit this vulnerability.

The specific flaw exists in the parsing of RPC requests to the LSA RPC interface. When parsing a request to LsarLookupSids/LsarLookupSids2, heap allocation is calculated based on user input. By specifying invalid values, heap blocks can be overwritten leading to remote code execution.