logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2018-20976

Description

An issue was discovered in fs/xfs/xfs_super.c in the Linux kernel before 4.18. A use after free exists, related to xfs_fs_fill_super failure.


Affected Package


OS OS Version Package Name Package Version
ubuntu 12.04 linux any
ubuntu 14.04 linux any
ubuntu upstream linux 4.18~rc1
ubuntu 16.04 linux 4.4.0-165.193
ubuntu 14.04 linux-aws any
ubuntu upstream linux-aws 4.18~rc1
ubuntu 16.04 linux-aws 4.4.0-1095.106
ubuntu upstream linux-aws-5.0 4.18~rc1
ubuntu upstream linux-aws-hwe 4.18~rc1
ubuntu 16.04 linux-aws-hwe 4.15.0-1051.53~16.04.1
ubuntu 14.04 linux-azure any
ubuntu upstream linux-azure 4.18~rc1
ubuntu 16.04 linux-azure 4.15.0-1060.65
ubuntu upstream linux-azure-5.3 4.18~rc1
ubuntu upstream linux-azure-edge 4.18~rc1
ubuntu 16.04 linux-azure-edge 4.15.0-1060.65
ubuntu upstream linux-gcp 4.18~rc1
ubuntu 16.04 linux-gcp 4.15.0-1046.49
ubuntu upstream linux-gcp-5.3 4.18~rc1
ubuntu upstream linux-gcp-edge 4.18~rc1
ubuntu upstream linux-gke-4.15 4.18~rc1
ubuntu upstream linux-gke-5.0 4.18~rc1
ubuntu upstream linux-gke-5.3 4.18~rc1
ubuntu upstream linux-hwe 4.18~rc1
ubuntu 16.04 linux-hwe 4.15.0-65.74~16.04.1
ubuntu upstream linux-hwe-edge 4.18~rc1
ubuntu 16.04 linux-hwe-edge 4.15.0-65.74~16.04.1
ubuntu upstream linux-kvm 4.18~rc1
ubuntu 16.04 linux-kvm 4.4.0-1059.66
ubuntu 12.04 linux-lts-trusty any
ubuntu upstream linux-lts-trusty 4.18~rc1
ubuntu 14.04 linux-lts-xenial any
ubuntu upstream linux-lts-xenial 4.18~rc1
ubuntu 19.10 linux-oem 4.15.0-1057.66
ubuntu upstream linux-oem 4.18~rc1
ubuntu 16.04 linux-oem any
ubuntu upstream linux-oem-5.6 4.18~rc1
ubuntu upstream linux-oem-osp1 4.18~rc1
ubuntu 19.04 linux-oracle 5.0.0-1004.8
ubuntu upstream linux-oracle 4.18~rc1
ubuntu 16.04 linux-oracle 4.15.0-1026.29~16.04.1
ubuntu upstream linux-oracle-5.0 4.18~rc1
ubuntu upstream linux-oracle-5.3 4.18~rc1
ubuntu upstream linux-raspi2 4.18~rc1
ubuntu 16.04 linux-raspi2 4.4.0-1123.132
ubuntu upstream linux-raspi2-5.3 4.18~rc1
ubuntu upstream linux-snapdragon 4.18~rc1
ubuntu 16.04 linux-snapdragon 4.4.0-1127.135

Related