logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2016-7117

Description

Use-after-free vulnerability in the __sys_recvmmsg function in net/socket.c in the Linux kernel before 4.5.2 allows remote attackers to execute arbitrary code via vectors involving a recvmmsg system call that is mishandled during error processing. #### Notes Author| Note ---|--- [jdstrand](<https://launchpad.net/~jdstrand>) | android kernels (flo, goldfish, grouper, maguro, mako and manta) are not supported on the Ubuntu Touch 14.10 and earlier preview kernels linux-lts-saucy no longer receives official support linux-lts-quantal no longer receives official support


Affected Package


OS OS Version Package Name Package Version
ubuntu 14.04 linux 3.13.0-86.130
ubuntu upstream linux 4.6~rc1
ubuntu 16.04 linux 4.4.0-22.39
ubuntu upstream linux-armadaxp 4.6~rc1
ubuntu upstream linux-aws 4.6~rc1
ubuntu upstream linux-flo 4.6~rc1
ubuntu upstream linux-gke 4.6~rc1
ubuntu upstream linux-goldfish 4.6~rc1
ubuntu upstream linux-grouper 4.6~rc1
ubuntu upstream linux-hwe 4.6~rc1
ubuntu upstream linux-hwe-edge 4.6~rc1
ubuntu upstream linux-linaro-omap 4.6~rc1
ubuntu upstream linux-linaro-shared 4.6~rc1
ubuntu upstream linux-linaro-vexpress 4.6~rc1
ubuntu upstream linux-lts-quantal 4.6~rc1
ubuntu upstream linux-lts-raring 4.6~rc1
ubuntu upstream linux-lts-saucy 4.6~rc1
ubuntu upstream linux-lts-trusty 4.6~rc1
ubuntu upstream linux-lts-utopic 4.6~rc1
ubuntu 14.04 linux-lts-vivid trusty was released [3.19.0-59.65~14.04.1]
ubuntu upstream linux-lts-vivid 4.6~rc1
ubuntu upstream linux-lts-wily 4.6~rc1
ubuntu 14.04 linux-lts-xenial 4.4.0-22.39~14.04.1
ubuntu upstream linux-lts-xenial 4.6~rc1
ubuntu upstream linux-maguro 4.6~rc1
ubuntu upstream linux-mako 4.6~rc1
ubuntu upstream linux-manta 4.6~rc1
ubuntu upstream linux-qcm-msm 4.6~rc1
ubuntu upstream linux-raspi2 4.6~rc1
ubuntu 16.04 linux-raspi2 4.4.0-1010.12
ubuntu upstream linux-snapdragon 4.6~rc1
ubuntu 16.04 linux-snapdragon 4.4.0-1013.14
ubuntu upstream linux-ti-omap4 4.6~rc1

Related