Lucene search

K
symantecSymantec Security ResponseSMNTC-111288
HistoryDec 03, 2019 - 12:00 a.m.

Kubernetes API Server CVE-2018-1002102 Open Redirection Vulnerability

2019-12-0300:00:00
Symantec Security Response
www.symantec.com
14

0.001 Low

EPSS

Percentile

22.6%

Description

Kubernetes API Server is prone to an open-redirection vulnerability. An attacker can leverage this issue by constructing a crafted URI and enticing a user to follow it. When an unsuspecting victim follows the link, they may be redirected to an attacker-controlled site; this may aid in phishing attacks. Other attacks are possible. Versions prior to Kubernetes 1.14.0 are vulnerable.

Technologies Affected

  • Kubernetes Kubernetes 1.0.0
  • Kubernetes Kubernetes 1.10.0
  • Kubernetes Kubernetes 1.10.1
  • Kubernetes Kubernetes 1.10.10
  • Kubernetes Kubernetes 1.10.11
  • Kubernetes Kubernetes 1.10.12
  • Kubernetes Kubernetes 1.10.2
  • Kubernetes Kubernetes 1.10.3
  • Kubernetes Kubernetes 1.10.4
  • Kubernetes Kubernetes 1.10.5
  • Kubernetes Kubernetes 1.10.6
  • Kubernetes Kubernetes 1.10.7
  • Kubernetes Kubernetes 1.10.8
  • Kubernetes Kubernetes 1.10.9
  • Kubernetes Kubernetes 1.11.0
  • Kubernetes Kubernetes 1.11.1
  • Kubernetes Kubernetes 1.11.2
  • Kubernetes Kubernetes 1.11.3
  • Kubernetes Kubernetes 1.11.4
  • Kubernetes Kubernetes 1.11.5
  • Kubernetes Kubernetes 1.11.6
  • Kubernetes Kubernetes 1.11.7
  • Kubernetes Kubernetes 1.11.8
  • Kubernetes Kubernetes 1.11.9
  • Kubernetes Kubernetes 1.12.0
  • Kubernetes Kubernetes 1.12.1
  • Kubernetes Kubernetes 1.12.10
  • Kubernetes Kubernetes 1.12.2
  • Kubernetes Kubernetes 1.12.3
  • Kubernetes Kubernetes 1.12.4
  • Kubernetes Kubernetes 1.12.5
  • Kubernetes Kubernetes 1.12.6
  • Kubernetes Kubernetes 1.12.7
  • Kubernetes Kubernetes 1.12.9
  • Kubernetes Kubernetes 1.13.0
  • Kubernetes Kubernetes 1.13.11
  • Kubernetes Kubernetes 1.13.12
  • Kubernetes Kubernetes 1.13.3
  • Kubernetes Kubernetes 1.13.4
  • Kubernetes Kubernetes 1.13.5
  • Kubernetes Kubernetes 1.13.6
  • Kubernetes Kubernetes 1.13.8
  • Kubernetes Kubernetes 1.13.9

Recommendations

Block external access at the network boundary, unless external parties require service.
If global access isn’t needed, filter access to the affected computer at the network boundary. Restricting access to only trusted computers and networks might greatly reduce the likelihood of a successful exploit.

Run all software as a nonprivileged user with minimal access rights.
To reduce the impact of latent vulnerabilities, always run nonadministrative software as an unprivileged user with minimal access rights.

Deploy network intrusion detection systems to monitor network traffic for malicious activity.
Deploy NIDS to detect and block attacks and anomalous activity such as requests containing suspicious URI sequences. Since the webserver may log such requests, review its logs regularly.

Do not follow links provided by unknown or untrusted sources.
To reduce the likelihood of successful exploits, never visit sites of questionable integrity or follow links provided by unfamiliar or untrusted sources.

Updates are available. Please see the references or vendor advisory for more information.