Lucene search

K
ibmIBM5D69CBA06173248955EBF3CEC3225415AF0A4C9D9CE2DF1B53FDA6911B9CA431
HistoryJan 14, 2021 - 1:24 p.m.

Security Bulletin: Red Hat OpenShift on IBM Cloud is affected by a Kubernetes API server security vulnerability (CVE-2018-1002102)

2021-01-1413:24:15
www.ibm.com
6

2.6 Low

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

HIGH

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N

2.1 Low

CVSS2

Access Vector

NETWORK

Access Complexity

HIGH

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:H/Au:S/C:P/I:N/A:N

0.001 Low

EPSS

Percentile

22.7%

Summary

Red Hat OpenShift on IBM Cloud is affected by a security vulnerability in the Kubernetes API server that allows a compromised node to redirect API server requests from streaming endpoints to arbitrary hosts (CVE-2018-1002102)

Vulnerability Details

CVEID: CVE-2018-1002102

Description: Improper validation of URL redirection in the Kubernetes API server in versions prior to v1.14.0 allows an attacker-controlled Kubelet to redirect API server requests from streaming endpoints to arbitrary hosts. Impacted API servers will follow the redirect as a GET request with client-certificate credentials for authenticating to the Kubelet.
CVSS Base Score: 2.6
CVSS Temporal Score: <https://exchange.xforce.ibmcloud.com/vulnerabilities/172732&gt; for more information
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N)

Affected Products and Versions

Red Hat OpenShift on IBM Cloud 3.11.0-3.11.318

Remediation/Fixes

Updates for Red Hat OpenShift on IBM Cloud clusters at version 3.11 are available that fix this vulnerability. Red Hat OpenShift on IBM Cloud will attempt to automatically apply the fix to your cluster master. There is no need to update cluster worker nodes for this vulnerability. In addition, clusters running version 4 are not affected.

To verify your clusters are no longer exposed to this vulnerability, use the following IBM Cloud CLI command to confirm your cluster master versions:

ibmcloud oc clusters

If your cluster masters are at version 3.11.346 or later, they are no longer exposed to this vulnerability.

If one or more of your clusters has not had its master automatically updated then use the following IBM Cloud CLI command to complete the cluster master update.

ibmcloud oc cluster master update --cluster &lt;cluster name or ID&gt; --version 3.11_openshift

Red Hat OpenShift on IBM Cloud version 3.11 is deprecated. See the Red Hat OpenShift on IBM Cloud version information and update actions documentation for more information about OpenShift versions and version support policies.

Monitor IBM Cloud Status for Future Security Bulletins

Monitor the security notifications on the IBM Cloud Status page to be advised of future security bulletins.

References

Complete CVSS v3 Guide
On-line Calculator v3

Off

CVE-2018-1002102: Unvalidated redirect

Related Information

IBM Secure Engineering Web Portal
IBM Product Security Incident Response Blog

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

Review the IBM security bulletin disclaimer and definitions regarding your responsibilities for assessing potential impact of security vulnerabilities to your environment.

[{“Business Unit”:{“code”:“BU059”,“label”:“IBM Software w/o TPS”},“Product”:{“code”:“SSJTBP”,“label”:“IBM Cloud Kubernetes Service”},“Component”:“–”,“Platform”:[{“code”:“PF025”,“label”:“Platform Independent”}],“Version”:“All Versions”,“Edition”:“”,“Line of Business”:{“code”:“LOB21”,“label”:“Public Cloud Platform”}}]

CPENameOperatorVersion
ibm cloud kubernetes serviceeqany

2.6 Low

CVSS3

Attack Vector

NETWORK

Attack Complexity

HIGH

Privileges Required

HIGH

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

NONE

Availability Impact

NONE

CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N

2.1 Low

CVSS2

Access Vector

NETWORK

Access Complexity

HIGH

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

NONE

Availability Impact

NONE

AV:N/AC:H/Au:S/C:P/I:N/A:N

0.001 Low

EPSS

Percentile

22.7%

Related for 5D69CBA06173248955EBF3CEC3225415AF0A4C9D9CE2DF1B53FDA6911B9CA431