Lucene search

K
suseSuseOPENSUSE-SU-2020:0105-1
HistoryJan 26, 2020 - 12:00 a.m.

Security update for libvpx (important)

2020-01-2600:00:00
lists.opensuse.org
116

0.011 Low

EPSS

Percentile

84.5%

An update that fixes 5 vulnerabilities is now available.

Description:

This update for libvpx fixes the following issues:

  • CVE-2019-2126: Fixed a double free in ParseContentEncodingEntry()
    (bsc#1160611).
  • CVE-2019-9325: Fixed an out-of-bounds read (bsc#1160612).
  • CVE-2019-9232: Fixed an out-of-bounds memory access on fuzzed data
    (bsc#1160613).
  • CVE-2019-9433: Fixed a use-after-free in vp8_deblock() (bsc#1160614).
  • CVE-2019-9371: Fixed a resource exhaustion after memory leak
    (bsc#1160615).

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

  • openSUSE Leap 15.1:

    zypper in -t patch openSUSE-2020-105=1

OSVersionArchitecturePackageVersionFilename
openSUSE Leap15.1i586< - openSUSE Leap 15.1 (i586 x86_64):- openSUSE Leap 15.1 (i586 x86_64):.i586.rpm
openSUSE Leap15.1x86_64< - openSUSE Leap 15.1 (i586 x86_64):- openSUSE Leap 15.1 (i586 x86_64):.x86_64.rpm
openSUSE Leap15.1x86_64< - openSUSE Leap 15.1 (x86_64):- openSUSE Leap 15.1 (x86_64):.x86_64.rpm