Lucene search

K
seebugRootSSV:12512
HistoryOct 22, 2009 - 12:00 a.m.

phpMyAdmin SQL注入和跨站脚本漏洞

2009-10-2200:00:00
Root
www.seebug.org
22

0.005 Low

EPSS

Percentile

77.1%

BUGTRAQ ID: 36658
CVE ID: CVE-2009-3697,CVE-2009-3696

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin没有正确地过滤对MySQL表格名称所提交的输入参数,远程攻击者可以通过提交恶意请求执行存储式跨站脚本攻击,并在用户浏览恶意数据时执行所注入的HTML和脚本代码;此外phpMyAdmin还没有正确地过滤提交给PDF schema生成器功能的各种参数,远程攻击者可以通过提交恶意请求执行SQL注入攻击。

phpMyAdmin 3.x
phpMyAdmin 2.11.x
厂商补丁:

phpMyAdmin

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.phpmyadmin.net/