[SA17085] CA iGateway Debug Mode HTTP GET Request Buffer Overflow

2005-10-13T00:00:00
ID SECURITYVULNS:DOC:9932
Type securityvulns
Reporter Securityvulns
Modified 2005-10-13T00:00:00

Description

TITLE: CA iGateway Debug Mode HTTP GET Request Buffer Overflow

SECUNIA ADVISORY ID: SA17085

VERIFY ADVISORY: http://secunia.com/advisories/17085/

CRITICAL: Moderately critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: CA iGateway 4.x http://secunia.com/product/5821/ CA iGateway 3.x http://secunia.com/product/5820/

DESCRIPTION: Erika Mendoza has reported a vulnerability in CA iGateway, which can be exploited by malicious people to compromise a vulnerable system.

The vulnerability is caused due to a boundary error when parsing HTTP GET requests. This can be exploited to cause a buffer overflow and allows arbitrary code execution.

Successful exploitation requires that debug mode is enabled.

The vulnerability has been reported in version 3.0 and 4.0 released prior to 2005-06-23.

Note: Exploit code for this vulnerability is publicly available.

SOLUTION: The vendor recommends that iGateway should not be run in debug mode.

PROVIDED AND/OR DISCOVERED BY: Erika Mendoza

ORIGINAL ADVISORY: http://www3.ca.com/threatinfo/vulninfo/vuln.aspx?id=33485


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.