[SA16511] AreaEdit SpellChecker Plugin Code Execution Vulnerability

2005-08-23T00:00:00
ID SECURITYVULNS:DOC:9560
Type securityvulns
Reporter Securityvulns
Modified 2005-08-23T00:00:00

Description


Bist Du interessiert an einem neuen Job in IT-Sicherheit?

Secunia hat zwei freie Stellen als Junior und Senior Spezialist in IT- Sicherheit: http://secunia.com/secunia_vacancies/


TITLE: AreaEdit SpellChecker Plugin Code Execution Vulnerability

SECUNIA ADVISORY ID: SA16511

VERIFY ADVISORY: http://secunia.com/advisories/16511/

CRITICAL: Highly critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: AreaEdit 0.x http://secunia.com/product/5599/

DESCRIPTION: A vulnerability has been reported in AreaEdit, which can be exploited by malicious people to compromise a vulnerable system.

Input passed to the "dictionary" variable in aspell_setup.php is not properly sanitised before being used as command line arguments. This can be exploited to inject arbitrary shell commands via a specially crafted string containing shell meta characters.

Successful exploitation does not require that the plugin has been enabled.

SOLUTION: Update to version 0.4.3.

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.

ORIGINAL ADVISORY: http://www.formvista.com/index.html?COMP=clog_list&cmd=detail&cs_clog_entries_ref=50


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.