[SA15865] Comdev eCommerce Review Script Insertion Vulnerability

2005-06-30T00:00:00
ID SECURITYVULNS:DOC:9020
Type securityvulns
Reporter Securityvulns
Modified 2005-06-30T00:00:00

Description


Bist Du interessiert an einem neuen Job in IT-Sicherheit?

Secunia hat zwei freie Stellen als Junior und Senior Spezialist in IT- Sicherheit: http://secunia.com/secunia_vacancies/


TITLE: Comdev eCommerce Review Script Insertion Vulnerability

SECUNIA ADVISORY ID: SA15865

VERIFY ADVISORY: http://secunia.com/advisories/15865/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: Comdev eCommerce 3.x http://secunia.com/product/4572/

DESCRIPTION: basher13 has reported a vulnerability in Comdev eCommerce, which can be exploited by malicious people to conduct script insertion attacks.

Input passed when posting a review is not properly sanitised before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of a vulnerable site when the malicious user data is viewed.

The vulnerability has been reported in version 3.1. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: basher13

ORIGINAL ADVISORY: http://k.domaindlx.com/shellcore/advisories.asp?bug_report=display&infamous_group=64


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.