[SA15584] Popper "form" File Inclusion Vulnerability

2005-06-03T00:00:00
ID SECURITYVULNS:DOC:8787
Type securityvulns
Reporter Securityvulns
Modified 2005-06-03T00:00:00

Description


Bist Du interessiert an einem neuen Job in IT-Sicherheit?

Secunia hat zwei freie Stellen als Junior und Senior Spezialist in IT- Sicherheit: http://secunia.com/secunia_vacancies/


TITLE: Popper "form" File Inclusion Vulnerability

SECUNIA ADVISORY ID: SA15584

VERIFY ADVISORY: http://secunia.com/advisories/15584/

CRITICAL: Highly critical

IMPACT: System access

WHERE: >From remote

SOFTWARE: Popper 1.x http://secunia.com/product/5206/

DESCRIPTION: Leon Juranic has reported a vulnerability in Popper, which can be exploited by malicious people to compromise a vulnerable system.

Input passed to the "form" parameter in "childwindow.inc.php" isn't properly verified, before it is used to include files. This can be exploited to include arbitrary files from external and local resources.

Successful exploitation requires that "register_globals" is enabled.

The vulnerability has been reported in version 1.41-r2 and prior.

SOLUTION: Set "register_globals" to "Off".

Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: Leon Juranic, LSS Security

ORIGINAL ADVISORY: http://security.lss.hr/en/index.php?page=details&ID=LSS-2005-06-07


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.