[SA15544] Fast n Furious DtDNS Updater Command Line Argument Disclosure

2005-05-30T00:00:00
ID SECURITYVULNS:DOC:8751
Type securityvulns
Reporter Securityvulns
Modified 2005-05-30T00:00:00

Description


Bist Du interessiert an einem neuen Job in IT-Sicherheit?

Secunia hat zwei freie Stellen als Junior und Senior Spezialist in IT- Sicherheit: http://secunia.com/secunia_vacancies/


TITLE: Fast n Furious DtDNS Updater Command Line Argument Disclosure

SECUNIA ADVISORY ID: SA15544

VERIFY ADVISORY: http://secunia.com/advisories/15544/

CRITICAL: Less critical

IMPACT: Exposure of sensitive information

WHERE: Local system

SOFTWARE: Fast n Furious DtDNS Updater 1.x http://secunia.com/product/5174/

DESCRIPTION: A security issue has been reported in Fast n Furious DtDNS Updater, which may disclose sensitive information to malicious, local users.

The problem is that any user on the system can gain knowledge of command line arguments passed to the program via e.g. "ps aux".

SOLUTION: The security issue has been partially fixed in version 1.3.

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.