[SA14688] Double Choco Latte Cross-Site Scripting and PHP Code Execution

2005-03-24T00:00:00
ID SECURITYVULNS:DOC:8150
Type securityvulns
Reporter Securityvulns
Modified 2005-03-24T00:00:00

Description


Want a new IT Security job?

Vacant positions at Secunia: http://secunia.com/secunia_vacancies/


TITLE: Double Choco Latte Cross-Site Scripting and PHP Code Execution

SECUNIA ADVISORY ID: SA14688

VERIFY ADVISORY: http://secunia.com/advisories/14688/

CRITICAL: Highly critical

IMPACT: Cross Site Scripting, System access

WHERE: >From remote

SOFTWARE: Double Choco Latte 0.x http://secunia.com/product/2658/

DESCRIPTION: James Bercegay has reported two vulnerabilities in Double Choco Latte, which can be exploited by malicious people to conduct cross-site scripting attacks and potentially compromise a vulnerable system.

1) Some unspecified input isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of a vulnerable site.

The vulnerability has been reported in version 0.9.4.3.

2) The vulnerability is caused due to an unspecified error, which can be exploited to execute arbitrary PHP code.

The vulnerability has been reported in version 0.9.4.2. Prior versions may also be affected.

SOLUTION: Update to version 0.9.4.4. http://sourceforge.net/project/showfiles.php?group_id=1424

PROVIDED AND/OR DISCOVERED BY: James Bercegay, GulfTech Research and Development


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.