[SA14124] Mambo Global Variables Security Bypass Vulnerability

2005-02-05T00:00:00
ID SECURITYVULNS:DOC:7746
Type securityvulns
Reporter Securityvulns
Modified 2005-02-05T00:00:00

Description

TITLE: Mambo Global Variables Security Bypass Vulnerability

SECUNIA ADVISORY ID: SA14124

VERIFY ADVISORY: http://secunia.com/advisories/14124/

CRITICAL: Moderately critical

IMPACT: Security Bypass

WHERE: >From remote

SOFTWARE: Mambo 4.x http://secunia.com/product/872/

DESCRIPTION: A vulnerability has been reported in Mambo, which can be exploited by malicious people to bypass certain security restrictions.

The problem is that global variables are not properly protected. This can be exploited to gain administrative privileges and access the database.

The vulnerability has been reported in version 4.5.1 and prior.

SOLUTION: Apply patch for version 4.5 and 4.5.1. http://www.mamboportal.com/component/option,com_remository/Itemid,46/

PROVIDED AND/OR DISCOVERED BY: Reported by vendor.

ORIGINAL ADVISORY: http://www.mamboportal.com/content/view/2008/2/


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.