[SA14063] SnugServer FTP Server Directory Traversal Vulnerability

2005-01-30T00:00:00
ID SECURITYVULNS:DOC:7715
Type securityvulns
Reporter Securityvulns
Modified 2005-01-30T00:00:00

Description

TITLE: SnugServer FTP Server Directory Traversal Vulnerability

SECUNIA ADVISORY ID: SA14063

VERIFY ADVISORY: http://secunia.com/advisories/14063/

CRITICAL: Moderately critical

IMPACT: Exposure of sensitive information

WHERE: >From remote

SOFTWARE: SnugServer 3.x http://secunia.com/product/4576/

DESCRIPTION: muts has reported a vulnerability in SnugServer, which can be exploited by malicious users to disclose sensitive information.

The vulnerability is caused due to an input validation error, making it possible to access arbitrary files outside the ftp root via directory traversal attacks.

The vulnerability has been reported in version 3.0.0.40. Other versions may also be affected.

SOLUTION: Update to version 3.0.0.44. http://www.snugserver.com/download.php

PROVIDED AND/OR DISCOVERED BY: muts


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.