[SA13574] PHP-Nuke Workboard Module Cross-Site Scripting

2004-12-22T00:00:00
ID SECURITYVULNS:DOC:7411
Type securityvulns
Reporter Securityvulns
Modified 2004-12-22T00:00:00

Description

TITLE: PHP-Nuke Workboard Module Cross-Site Scripting

SECUNIA ADVISORY ID: SA13574

VERIFY ADVISORY: http://secunia.com/advisories/13574/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: Workboard 1.x (module for PHP-Nuke) http://secunia.com/product/4432/

DESCRIPTION: Lostmon has reported two vulnerabilities in the Workboard module for PHP-Nuke, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed to the "project_id" and "task_id" parameters in "modules.php" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of a vulnerable site.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: Lostmon

ORIGINAL ADVISORY: http://lostmon.blogspot.com/2004/12/workboard-input-validation-error-in.html


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.