[SA13241] phpMyAdmin Cross-Site Scripting Vulnerabilities

2004-11-19T00:00:00
ID SECURITYVULNS:DOC:7208
Type securityvulns
Reporter Securityvulns
Modified 2004-11-19T00:00:00

Description

TITLE: phpMyAdmin Cross-Site Scripting Vulnerabilities

SECUNIA ADVISORY ID: SA13241

VERIFY ADVISORY: http://secunia.com/advisories/13241/

CRITICAL: Less critical

IMPACT: Cross Site Scripting

WHERE: >From remote

SOFTWARE: phpMyAdmin 2.x http://secunia.com/product/1720/

DESCRIPTION: Cedric Cochin has reported some vulnerabilities in phpMyAdmin, which can be exploited by malicious people to conduct cross-site scripting attacks.

Input passed to the "zero_rows" and "sql_query" parameters in "read_dump.php" and the "PmaAbsoluteUri" parameter is not sufficiently sanitised before being returned to users. This can be exploited to execute arbitrary HTML or script code in a user's browser session in context of a vulnerable site.

SOLUTION: Update to version 2.6.0-pl3. http://www.phpmyadmin.net/home_page/downloads.php

PROVIDED AND/OR DISCOVERED BY: Cedric Cochin

ORIGINAL ADVISORY: Vendor: http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2004-3

netVigilance: http://www.netvigilance.com/html/advisory0005.htm


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.