[SA13201] PunBB Private Message System Module Two Vulnerabilities

2004-11-16T00:00:00
ID SECURITYVULNS:DOC:7196
Type securityvulns
Reporter Securityvulns
Modified 2004-11-16T00:00:00

Description

TITLE: PunBB Private Message System Module Two Vulnerabilities

SECUNIA ADVISORY ID: SA13201

VERIFY ADVISORY: http://secunia.com/advisories/13201/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting, Exposure of sensitive information

WHERE: >From remote

SOFTWARE: Private Message System (module for PunBB) 1.x http://secunia.com/product/4255/

DESCRIPTION: Digital-X has reported two vulnerabilities in Private Message System module for PunBB, which can be exploited by malicious people to conduct cross-site scripting attacks and disclose sensitive information.

1) Input passed to the "tid" parameter in "message_send.php" isn't properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of a vulnerable site.

2) The ownership of private messages isn't properly verified in "message_send.php". This can be exploited to view private messages, which belong to another user.

The vulnerabilities have been reported in version 1.1.3. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised and that only the owners of a message can view it.

PROVIDED AND/OR DISCOVERED BY: Digital-X


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.