[SA13074] FsPHPGallery Denial of Service and Disclosure of System Information Vulnerabilities

2004-11-04T00:00:00
ID SECURITYVULNS:DOC:7129
Type securityvulns
Reporter Securityvulns
Modified 2004-11-04T00:00:00

Description


Monitor, Filter, and Manage Security Information - Filtering and Management of Secunia advisories - Overview, documentation, and detailed reports - Alerting via email and SMS

Request Trial: https://ca.secunia.com/?f=l


TITLE: FsPHPGallery Denial of Service and Disclosure of System Information Vulnerabilities

SECUNIA ADVISORY ID: SA13074

VERIFY ADVISORY: http://secunia.com/advisories/13074/

CRITICAL: Less critical

IMPACT: Exposure of system information, DoS

WHERE: >From remote

SOFTWARE: FsPHPGallery 1.x http://secunia.com/product/4207/

DESCRIPTION: Two vulnerabilities have been reported in FsPHPGallery, which can be exploited by malicious people to cause a DoS (Denial of Service) and disclose system information.

1) The vulnerability is caused due to an input validation error when resizing images. This can be exploited to cause a DoS on the server by supplying a large size attribute for an image.

2) Input passed to the "dir" parameter in "index.php" isn't properly verified before it is being used to list directories inside the web root. This can be exploited to disclose the contents of arbitrary directories using directory traversal attacks.

SOLUTION: Update to version 1.2: http://gallery.devrandom.org.uk/releases/fsphpgallery-1.2.tar.gz

PROVIDED AND/OR DISCOVERED BY: Reported by the vendor.


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.