[SA12955] dadaIMC "Post An Article" Script Insertion Vulnerability

2004-10-26T00:00:00
ID SECURITYVULNS:DOC:7071
Type securityvulns
Reporter Securityvulns
Modified 2004-10-26T00:00:00

Description

TITLE: dadaIMC "Post An Article" Script Insertion Vulnerability

SECUNIA ADVISORY ID: SA12955

VERIFY ADVISORY: http://secunia.com/advisories/12955/

CRITICAL: Moderately critical

IMPACT: Cross Site Scripting, Manipulation of data

WHERE: >From remote

SOFTWARE: dadaIMC 0.x http://secunia.com/product/4139/

DESCRIPTION: Elac has discovered a vulnerability in dadaIMC, which can be exploited by malicious people to conduct script insertion attacks.

Input passed to "newswire/index.php" when posting an article is not properly sanitised before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site when the malicious news article is viewed.

The vulnerability has been confirmed on version 0.98.1. Other versions may also be affected.

SOLUTION: Edit the source code to ensure that input is properly sanitised.

PROVIDED AND/OR DISCOVERED BY: Elac

ORIGINAL ADVISORY: http://www.rightwingextremist.net/main/index.php?option=content&task=view&id=23&Itemid=2

OTHER REFERENCES: OSVDB: http://www.osvdb.org/11052


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.