[SA12609] YaBB Input Validation Vulnerabilities

2004-09-28T00:00:00
ID SECURITYVULNS:DOC:6877
Type securityvulns
Reporter Securityvulns
Modified 2004-09-28T00:00:00

Description

TITLE: YaBB Input Validation Vulnerabilities

SECUNIA ADVISORY ID: SA12609

VERIFY ADVISORY: http://secunia.com/advisories/12609/

CRITICAL: Less critical

IMPACT: Cross Site Scripting, Manipulation of data

WHERE: >From remote

SOFTWARE: YaBB 1.x http://secunia.com/product/541/

DESCRIPTION: Two vulnerabilities have been reported in YaBB, which can be exploited to conduct cross-site scripting attacks and manipulate certain files.

1) An unspecified input validation error in "Adminedit.pl" reportedly allows code execution in "settings.pl".

2) An input validation error in the handling of the "subject" variable allows insertion of line breaks. This makes it possible for malicious user to manipulate the content in the related text file.

The vulnerabilities affect versions prior to version 1 GOLD SP 1.3.2.

SOLUTION: Update to version 1 GOLD SP 1.3.2. http://www.yabbforum.com/downloads.php

PROVIDED AND/OR DISCOVERED BY: 1) Reported by vendor. 2) Dmitry Shurupov

ORIGINAL ADVISORY: http://www.yabbforum.com/community/YaBB.pl?board=general;action=display;num=1093133233

OTHER REFERENCES: SA11128: http://secunia.com/advisories/11128/


About: This Advisory was delivered by Secunia as a free service to help everybody keeping their systems up to date against the latest vulnerabilities.

Subscribe: http://secunia.com/secunia_security_advisories/

Definitions: (Criticality, Where etc.) http://secunia.com/about_secunia_advisories/

Please Note: Secunia recommends that you verify all advisories you receive by clicking the link. Secunia NEVER sends attached files with advisories. Secunia does not advise people to install third party patches, only use those supplied by the vendor.