[Full-Disclosure] Icecast 2.0.0 preauth overflow

2004-05-11T00:00:00
ID SECURITYVULNS:DOC:6189
Type securityvulns
Reporter Securityvulns
Modified 2004-05-11T00:00:00

Description

There exists a remotely exploitable heap overflow in Icecast 2.0.0. The bug exists in the handling of base64 Authorization request. This bug was found in about 40 seconds during a HTTP audit of the web component of Icecast with the fuzzer SMUDGE (http://felinemenace.org/~nd/SMUDGE/)

People complained that the last Icecast bugs weren't preauth. This one is. Attached is a simple python script to reproduce the bug on the Windows platform. Our tests confirmed that some tweaking will crash linux version although this was not verified by the Icecast team.

Vendor == notified.

On another note tis signifies the first release from the UBC.

thanks, nd.

-- http://felinemenace.org/~nd